blob: 370cd7017b8ae2ed42e5cf231a1151b1c6ea4634 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
Patrick Williams44b3caf2024-04-12 16:51:14 -050011inherit ptest python_setuptools_build_meta
Andrew Geissler595f6302022-01-24 19:11:47 +000012
Patrick Williams44b3caf2024-04-12 16:51:14 -050013SRCREV = "f2e4081aee38f850938048beac7fb69c4908bc5e"
14SRC_URI = "git://github.com/hgrecco/pint;protocol=https;branch=master"
15S = "${WORKDIR}/git"
16#SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
Andrew Geissler595f6302022-01-24 19:11:47 +000017
18DEPENDS += "python3-setuptools-scm-native"
19
20BBCLASSEXTEND = "native nativesdk"
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
26RDEPENDS:${PN} += " \
Patrick Williams39653562024-03-01 08:54:02 -060027 python3-setuptools \
28 python3-packaging \
Andrew Geissler595f6302022-01-24 19:11:47 +000029"
30
31RDEPENDS:${PN}-ptest += " \
Patrick Williams44b3caf2024-04-12 16:51:14 -050032 python3-appdirs \
33 python3-flexcache \
34 python3-flexparser \
Patrick Williams39653562024-03-01 08:54:02 -060035 python3-pytest \
Andrew Geissler595f6302022-01-24 19:11:47 +000036"
37
38do_install_ptest() {
39 install -d ${D}${PTEST_PATH}/testsuite
Patrick Williams44b3caf2024-04-12 16:51:14 -050040 cp -rf ${S}/pint/* ${D}${PTEST_PATH}/
Andrew Geissler595f6302022-01-24 19:11:47 +000041}