Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Physical quantities module" |
| 2 | DESCRIPTION = "Physical quantities Python module" |
| 3 | HOMEPAGE = "https://github.com/hgrecco/pint" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" |
| 8 | |
| 9 | PYPI_PACKAGE := "Pint" |
| 10 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 11 | inherit ptest python_setuptools_build_meta |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 13 | SRCREV = "f2e4081aee38f850938048beac7fb69c4908bc5e" |
| 14 | SRC_URI = "git://github.com/hgrecco/pint;protocol=https;branch=master" |
| 15 | S = "${WORKDIR}/git" |
| 16 | #SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | |
| 18 | DEPENDS += "python3-setuptools-scm-native" |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |
| 21 | |
| 22 | SRC_URI += " \ |
| 23 | file://run-ptest \ |
| 24 | " |
| 25 | |
| 26 | RDEPENDS:${PN} += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 27 | python3-setuptools \ |
| 28 | python3-packaging \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 29 | " |
| 30 | |
| 31 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 32 | python3-appdirs \ |
| 33 | python3-flexcache \ |
| 34 | python3-flexparser \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 35 | python3-pytest \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 36 | " |
| 37 | |
| 38 | do_install_ptest() { |
| 39 | install -d ${D}${PTEST_PATH}/testsuite |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 40 | cp -rf ${S}/pint/* ${D}${PTEST_PATH}/ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 41 | } |