Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "pytest plugin to test server connections locally." |
| 2 | HOMEPAGE = "https://github.com/pytest-dev/pytest-localserver" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b8da7a541d738b054dcbf70c31530432" |
| 5 | |
| 6 | DEPENDS += "python3-setuptools-scm-native" |
| 7 | |
| 8 | inherit pypi python_setuptools_build_meta ptest |
| 9 | |
| 10 | SRC_URI[sha256sum] = "66569c34fef31a5750b16effd1cd1288a7a90b59155d005e7f916accd3dee4f1" |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | RDEPENDS:${PN}-ptest += " \ |
| 17 | python3-pytest \ |
| 18 | python3-requests \ |
| 19 | python3-unittest-automake-output \ |
| 20 | " |
| 21 | |
| 22 | do_install_ptest() { |
| 23 | install -d ${D}${PTEST_PATH}/tests |
| 24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 25 | } |
| 26 | |
| 27 | RDEPENDS:${PN} += " \ |
| 28 | python3-werkzeug \ |
| 29 | " |