blob: e741b6268ddc2708696fd64d5d2d103c39a51798 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# This recipe is originally from meta-openstack:
2# https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python3-uritemplate_3.0.0.bb?h=master
3
4SUMMARY = "Simple python library to deal with URI Templates."
Andrew Geisslereff27472021-10-29 15:35:00 -05005LICENSE = "Apache-2.0 | BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0f6d769bdcfacac3c1a1ffa568937fe0"
7
8SRC_URI[sha256sum] = "4346edfc5c3b79f694bccd6d6099a322bbeb628dbf2cd86eea55a456ce5124f0"
9
10inherit pypi setuptools3 ptest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060017 python3-pytest \
18 python3-unittest-automake-output \
Andrew Geisslereff27472021-10-29 15:35:00 -050019"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"