Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Tracker is a file search engine" |
| 2 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
| 3 | LIC_FILES_CHKSUM = " \ |
| 4 | file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \ |
| 5 | file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 6 | " |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | dbus-native \ |
| 10 | python3-pygobject-native \ |
| 11 | glib-2.0 \ |
| 12 | sqlite3 \ |
| 13 | libarchive \ |
| 14 | dbus \ |
| 15 | icu \ |
| 16 | json-glib \ |
| 17 | libsoup-3.0 \ |
| 18 | libstemmer \ |
| 19 | " |
| 20 | |
| 21 | GNOMEBASEBUILDCLASS = "meson" |
| 22 | |
| 23 | inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check python3native |
| 24 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 25 | SRC_URI += "file://0001-meson-Do-not-define-TOP_SRCDIR.patch" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 26 | SRC_URI[archive.sha256sum] = "f972d50ac7bafdccf113b1eb99dcae35404685a99e55bfef16f3ac83b4de974d" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 27 | |
| 28 | # gobject-introspection is mandatory and cannot be configured |
| 29 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 30 | GIR_MESON_OPTION = "" |
| 31 | |
| 32 | # text search is not an option anymore and requires sqlite3 build with |
| 33 | # PACKAGECONFIG[fts5] set (default) |
| 34 | |
| 35 | # set required cross property sqlite3_has_fts5 |
| 36 | do_write_config[vardeps] += "PACKAGECONFIG" |
| 37 | do_write_config:append() { |
| 38 | echo "[properties]" > ${WORKDIR}/meson-tracker.cross |
| 39 | echo "sqlite3_has_fts5 = 'true'" >> ${WORKDIR}/meson-tracker.cross |
| 40 | } |
| 41 | |
| 42 | EXTRA_OEMESON = " \ |
| 43 | --cross-file ${WORKDIR}/meson-tracker.cross \ |
| 44 | -Dman=false \ |
| 45 | -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \ |
| 46 | -Dsystemd_user_services_dir=${systemd_user_unitdir} \ |
| 47 | -Dsoup=soup3 \ |
| 48 | " |
| 49 | |
| 50 | FILES:${PN} += " \ |
| 51 | ${datadir}/dbus-1 \ |
| 52 | ${datadir}/tracker3 \ |
| 53 | ${libdir}/tracker-3.0 \ |
| 54 | ${systemd_user_unitdir} \ |
| 55 | " |