blob: 697f102a2e9abbc76207e5ac4716a7b6ef4b6076 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The new Python SDK for Sentry.io"
2DESCRIPTION = "This is the next line of the Python SDK \
3for Sentry, intended to replace the raven package on PyPI."
4HOMEPAGE = "https://github.com/getsentry/sentry-python"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05005LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7fcb29c83dd48cb7b112d0dd81111a89"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8RDEPENDS:${PN} += "\
9 ${PYTHON_PN}-urllib3 \
10 ${PYTHON_PN}-core \
11 ${PYTHON_PN}-json \
12 ${PYTHON_PN}-logging \
13 ${PYTHON_PN}-threading \
14 ${PYTHON_PN}-compression \
15 ${PYTHON_PN}-datetime \
16"
17
Andrew Geissler8f840682023-07-21 09:09:43 -050018SRC_URI[sha256sum] = "760e4fb6d01c994110507133e08ecd4bdf4d75ee4be77f296a3579796cf73134"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20PYPI_PACKAGE = "sentry-sdk"
21
22inherit pypi setuptools3