Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | # Copyright (C) 2017 Armin Kuster <akuster808@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Lynis is a free and open source security and auditing tool." |
| 5 | HOMEDIR = "https://cisofy.com/" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 6 | LICENSE = "GPL-3.0-only" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3edd6782854304fd11da4975ab9799c1" |
| 8 | |
Andrew Geissler | dc9d614 | 2023-05-19 09:38:37 -0500 | [diff] [blame] | 9 | SRC_URI = "https://cisofy.com/files/${BPN}-${PV}.tar.gz \ |
| 10 | file://0001-osdetection-add-OpenEmbedded-and-Poky.patch \ |
| 11 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "98373a4cc9d0471ab9bebb249e442fcf94b6bf6d4e9c6fc0b22bca1506646c63" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/${BPN}" |
| 16 | |
| 17 | inherit autotools-brokensep |
| 18 | |
| 19 | do_compile[noexec] = "1" |
| 20 | do_configure[noexec] = "1" |
| 21 | |
| 22 | do_install () { |
| 23 | install -d ${D}/${bindir} |
| 24 | install -d ${D}/${sysconfdir}/lynis |
| 25 | install -m 555 ${S}/lynis ${D}/${bindir} |
| 26 | |
| 27 | install -d ${D}/${datadir}/lynis/db |
| 28 | install -d ${D}/${datadir}/lynis/plugins |
| 29 | install -d ${D}/${datadir}/lynis/include |
| 30 | install -d ${D}/${datadir}/lynis/extras |
| 31 | |
| 32 | cp -r ${S}/db/* ${D}/${datadir}/lynis/db/. |
| 33 | cp -r ${S}/plugins/* ${D}/${datadir}/lynis/plugins/. |
| 34 | cp -r ${S}/include/* ${D}/${datadir}/lynis/include/. |
| 35 | cp -r ${S}/extras/* ${D}/${datadir}/lynis/extras/. |
| 36 | cp ${S}/*.prf ${D}/${sysconfdir}/lynis |
| 37 | } |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | FILES:${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf" |
| 40 | FILES:${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | RDEPENDS:${PN} += "procps findutils" |