Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | |
| 2 | # enable the overrides for the context of the conf only |
| 3 | OVERRIDES .= ":qemuboot-xilinx" |
| 4 | |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 5 | # Default machine targets for Xilinx QEMU (FDT Generic) |
Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame] | 6 | # Allow QB_MACHINE to be overridden by a BSP config |
| 7 | QB_MACHINE ?= "${QB_MACHINE_XILINX}" |
Andrew Geissler | c60845c | 2021-01-29 15:55:05 -0600 | [diff] [blame] | 8 | QB_RNG="" |
Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame] | 9 | QB_MACHINE_XILINX_aarch64 = "-machine arm-generic-fdt" |
Andrew Geissler | c60845c | 2021-01-29 15:55:05 -0600 | [diff] [blame] | 10 | QB_MACHINE_XILINX_arm = "-M arm-generic-fdt-7series" |
| 11 | QB_MACHINE_XILINX_microblaze = "-M microblaze-fdt-plnx" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 12 | |
| 13 | # defaults |
| 14 | QB_DEFAULT_KERNEL ?= "none" |
| 15 | |
| 16 | inherit qemuboot |
| 17 | |
| 18 | # rewrite the qemuboot with the custom sysroot bindir |
| 19 | python do_write_qemuboot_conf_append() { |
| 20 | val = os.path.join(d.getVar('BASE_WORKDIR'), d.getVar('BUILD_SYS'), 'qemu-xilinx-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/') |
| 21 | cf.set('config_bsp', 'STAGING_BINDIR_NATIVE', '%s' % val) |
| 22 | |
| 23 | # write out the updated version from this append |
| 24 | with open(qemuboot, 'w') as f: |
| 25 | cf.write(f) |
| 26 | } |
| 27 | |