Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # |
| 2 | # Class to disable binconfig files instead of installing them |
| 3 | # |
| 4 | |
| 5 | # The list of scripts which should be disabled. |
| 6 | BINCONFIG ?= "" |
| 7 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 8 | FILES:${PN}-dev += "${bindir}/*-config" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 10 | do_install:append () { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | for x in ${BINCONFIG}; do |
| 12 | # Make the disabled script emit invalid parameters for those configure |
| 13 | # scripts which call it without checking the return code. |
| 14 | echo "#!/bin/sh" > ${D}$x |
| 15 | echo "echo 'ERROR: $x should not be used, use an alternative such as pkg-config' >&2" >> ${D}$x |
| 16 | echo "echo '--should-not-have-used-$x'" >> ${D}$x |
| 17 | echo "exit 1" >> ${D}$x |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | chmod +x ${D}$x |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | done |
| 20 | } |
| 21 | |
| 22 | SYSROOT_PREPROCESS_FUNCS += "binconfig_disabled_sysroot_preprocess" |
| 23 | |
| 24 | binconfig_disabled_sysroot_preprocess () { |
| 25 | for x in ${BINCONFIG}; do |
| 26 | configname=`basename $x` |
| 27 | install -d ${SYSROOT_DESTDIR}${bindir_crossscripts} |
| 28 | install ${D}$x ${SYSROOT_DESTDIR}${bindir_crossscripts} |
| 29 | done |
| 30 | } |