Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 1 | DESCRIPTION = "A file format designed for highly efficient deltas while maintaining good compression" |
| 2 | AUTHOR = "Jonathan Dieter" |
| 3 | |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242" |
| 6 | |
| 7 | SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main" |
| 8 | |
| 9 | SRCREV = "1d8f14484b4e0b507487abe6c294fb2059b7b72f" |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | DEPENDS = "zstd" |
| 13 | DEPENDS:append:libc-musl = " argp-standalone" |
| 14 | |
| 15 | inherit meson pkgconfig lib_package |
| 16 | |
| 17 | PACKAGECONFIG ??= "openssl zckdl" |
| 18 | |
| 19 | # zckdl gets packaged into zchunk-bin |
| 20 | PACKAGECONFIG[zckdl] = "-Dwith-curl=enabled,-Dwith-curl=disabled,curl" |
| 21 | # Use OpenSSL primitives for SHA |
| 22 | PACKAGECONFIG[openssl] = "-Dwith-openssl=enabled,-Dwith-openssl=disabled,openssl" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |