Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 1 | DESCRIPTION = "C++ client for Redis based on hiredis" |
| 2 | HOMEPAGE = "https://github.com/sewenew/redis-plus-plus" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 6 | |
| 7 | DEPENDS += "hiredis" |
| 8 | |
| 9 | SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \ |
| 10 | file://0001-CMakeLists.txt-fix-substitution-for-static-libs.patch" |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 11 | SRCREV = "ad6baa121f4c6fbc7622d83d606210ac22549c78" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake |
| 16 | |
| 17 | # if ssl is enabled for redis-plus-plus it must also be enabled for hiredis |
| 18 | PACKAGECONFIG ??= "ssl" |
| 19 | PACKAGECONFIG[ssl] = "-DREDIS_PLUS_PLUS_USE_TLS=ON, -DREDIS_PLUS_PLUS_USE_TLS=OFF, openssl" |
| 20 | PACKAGECONFIG[test] = "-DREDIS_PLUS_PLUS_BUILD_TEST=ON, -DREDIS_PLUS_PLUS_BUILD_TEST=OFF" |
| 21 | |
| 22 | do_install:append() { |
| 23 | # To remove absolute path in .cmake found by QA warning [buildpaths] |
| 24 | sed -i -e 's|${STAGING_LIBDIR}/libcrypto.so|crypto|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake |
| 25 | sed -i -e 's|${STAGING_LIBDIR}/libssl.so|ssl|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake |
| 26 | } |