blob: 05240edd7a2ac685d20664025969b0263615c296 [file] [log] [blame]
Joel Stanley34c894e2015-12-06 22:54:23 +10301SUMMARY = "pflash programmer for OpenPower"
2DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
3HOMEPAGE = "https://github.com/open-power"
4LICENSE = "Apache-2.0"
5
6SRC_URI += "git://github.com/open-power/skiboot.git"
Brad Bishopf64e73c2016-06-08 23:06:31 -04007
Joel Stanley34c894e2015-12-06 22:54:23 +10308LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
Patrick Williams7687a222016-07-28 05:42:24 -050010SRCREV = "skiboot-5.3.0"
11PV = "5.3.0"
Joel Stanley34c894e2015-12-06 22:54:23 +103012
13S = "${WORKDIR}/git"
14
Patrick Williams3d1dee02016-07-17 06:22:09 -050015EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} SKIBOOT_VERSION=${PV} PFLASH_VERSION=${PV} V=1'
Joel Stanley34c894e2015-12-06 22:54:23 +103016
17do_compile () {
Brad Bishopf64e73c2016-06-08 23:06:31 -040018 oe_runmake -C external/pflash all LINKAGE=dynamic
Joel Stanley34c894e2015-12-06 22:54:23 +103019}
20
21do_install () {
Brad Bishopf64e73c2016-06-08 23:06:31 -040022 oe_runmake -C external/pflash install LINKAGE=dynamic DESTDIR=${D} PREFIX=${D}/usr
Joel Stanley34c894e2015-12-06 22:54:23 +103023}
Brad Bishopf64e73c2016-06-08 23:06:31 -040024
25BBCLASSEXTEND = "native nativesdk"