Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=8f787620b7d3866d9552fd1924c07572 \ |
| 8 | file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc" |
| 9 | |
| 10 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases" |
| 11 | UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar" |
| 12 | |
| 13 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz \ |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 14 | " |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "6ad11d653347bd25d8317589df4e431a2de372c0cf9be3543368e07ec23bb8e7" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 16 | |
| 17 | inherit meson pkgconfig lib_package gtk-doc gobject-introspection |
| 18 | |
| 19 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 20 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 21 | GTKDOC_MESON_ENABLE_FLAG = 'enabled' |
| 22 | GTKDOC_MESON_DISABLE_FLAG = 'disabled' |
| 23 | |
| 24 | PACKAGECONFIG ??= "cairo fontconfig freetype glib icu" |
| 25 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 26 | PACKAGECONFIG[fontconfig] = "-Dfontconfig=enabled,-Dfontconfig=disabled,fontconfig" |
| 27 | PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype" |
| 28 | PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0" |
| 29 | PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2" |
| 30 | PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu" |
| 31 | |
| 32 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset" |
| 33 | |
| 34 | LEAD_SONAME = "libharfbuzz.so" |
| 35 | |
| 36 | do_install_append() { |
| 37 | # If no tools are installed due to PACKAGECONFIG then this directory is |
| 38 | #still installed, so remove it to stop packaging wanings. |
| 39 | rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 40 | } |
| 41 | |
| 42 | FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 43 | FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 44 | ${libdir}/libharfbuzz-icu.so \ |
| 45 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 46 | " |
| 47 | FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*" |
| 48 | |
| 49 | BBCLASSEXTEND = "native nativesdk" |