blob: 1a5d8a6b040152661f8b6c39754240b797e607ca [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Library for rendering SVG files"
2DESCRIPTION = "A small library to render Scalable Vector Graphics (SVG), \
3associated with the GNOME Project. It renders SVG files to Cairo surfaces. \
4Cairo is the 2D, antialiased drawing library that GNOME uses to draw things to \
5the screen or to generate output for printing."
6HOMEPAGE = "https://gitlab.gnome.org/GNOME/librsvg"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/librsvg/issues"
8
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
11 "
12
13SECTION = "x11/utils"
14DEPENDS = "cairo gdk-pixbuf glib-2.0 libxml2 pango python3-docutils-native"
15BBCLASSEXTEND = "native nativesdk"
16
Patrick Williamse760df82023-05-26 11:10:49 -050017inherit cargo_common gnomebase pixbufcache upstream-version-is-even gobject-introspection rust vala gi-docgen cargo-update-recipe-crates
18
19require ${BPN}-crates.inc
Patrick Williams92b42cb2022-09-03 06:53:57 -050020
21SRC_URI += "file://0001-Makefile.am-pass-rust-target-to-cargo-also-when-not-.patch \
Patrick Williamse760df82023-05-26 11:10:49 -050022 file://0001-system-deps-src-lib.rs-do-not-probe-into-harcoded-li.patch;patchdir=${CARGO_VENDORING_DIRECTORY} \
Patrick Williams92b42cb2022-09-03 06:53:57 -050023 "
24
Patrick Williamse760df82023-05-26 11:10:49 -050025SRC_URI[archive.sha256sum] = "194b5097d9cd107495f49c291cf0da65ec2b4bb55e5628369751a3f44ba222b3"
Patrick Williams92b42cb2022-09-03 06:53:57 -050026
27# librsvg is still autotools-based, but is calling cargo from its automake-driven makefiles
28# so we cannot use cargo class directly, but still need bits and pieces from it
29# for cargo to be happy
30BASEDEPENDS:append = " cargo-native"
31
32export RUST_BACKTRACE = "full"
33export RUSTFLAGS
34
35export RUST_TARGET = "${RUST_HOST_SYS}"
36
37RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
38RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
39RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
40RUSTFLAGS:append:riscv32 = " --cfg crossbeam_no_atomic_64"
41
Patrick Williams92b42cb2022-09-03 06:53:57 -050042do_configure[postfuncs] += "cargo_common_do_configure"
43
44inherit rust-target-config
45
Patrick Williams92b42cb2022-09-03 06:53:57 -050046# rust-cross writes the target linker binary into target json definition without any flags.
47# This breaks here because the linker isn't going to work without at least knowing where
48# the sysroot is. So copy the json to workdir, and patch in the path to wrapper from rust class
49# which supplies the needed flags.
50do_compile:prepend() {
51 sed -ie 's,"linker": ".*","linker": "${RUST_TARGET_CC}",g' ${RUST_TARGETS_DIR}/${RUST_HOST_SYS}.json
52}
53
54# Issue only on windows
55CVE_CHECK_IGNORE += "CVE-2018-1000041"
56
57CACHED_CONFIGUREVARS = "ac_cv_path_GDK_PIXBUF_QUERYLOADERS=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
58
59PACKAGECONFIG ??= "gdkpixbuf"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060060PACKAGECONFIG:append:class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vala', '', d)}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050061# The gdk-pixbuf loader
62PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060063PACKAGECONFIG[vala] = "--enable-vala,--disable-vala"
Patrick Williams92b42cb2022-09-03 06:53:57 -050064
65do_install:append() {
66 # Loadable modules don't need .a or .la on Linux
67 rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la
68}
69
70PACKAGES =+ "librsvg-gtk rsvg"
71FILES:rsvg = "${bindir}/rsvg* \
72 ${datadir}/pixmaps/svg-viewer.svg \
73 ${datadir}/themes"
74FILES:librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so \
75 ${datadir}/thumbnailers/librsvg.thumbnailer"
76RRECOMMENDS:librsvg-gtk = "gdk-pixbuf-bin"
77
78PIXBUF_PACKAGES = "librsvg-gtk"