Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | # |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 4 | # Corstone1000 64-bit machines |
| 5 | # |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 6 | DEPENDS:append:corstone1000 = " gnutls-native openssl-native efitools-native" |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 7 | CORSTONE1000_DEVICE_TREE:corstone1000-mps3 = "corstone1000-mps3" |
| 8 | CORSTONE1000_DEVICE_TREE:corstone1000-fvp = "corstone1000-fvp" |
| 9 | EXTRA_OEMAKE:append:corstone1000 = ' DEVICE_TREE=${CORSTONE1000_DEVICE_TREE}' |
| 10 | |
| 11 | SYSROOT_DIRS:append:corstone1000 = " /boot" |
| 12 | |
| 13 | SRC_URI:append:corstone1000 = " \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 14 | file://0001-FF-A-v15-arm64-smccc-add-support-for-SMCCCv1.2-x0-x1.patch \ |
| 15 | file://0002-FF-A-v15-lib-uuid-introduce-uuid_str_to_le_bin-funct.patch \ |
| 16 | file://0003-FF-A-v15-lib-uuid-introduce-testcase-for-uuid_str_to.patch \ |
| 17 | file://0004-FF-A-v15-arm_ffa-introduce-Arm-FF-A-support.patch \ |
| 18 | file://0005-FF-A-v15-arm_ffa-introduce-armffa-command.patch \ |
| 19 | file://0006-FF-A-v15-arm_ffa-introduce-sandbox-FF-A-support.patch \ |
| 20 | file://0007-FF-A-v15-arm_ffa-introduce-sandbox-test-cases-for-UC.patch \ |
| 21 | file://0008-FF-A-v15-arm_ffa-introduce-armffa-command-Sandbox-te.patch \ |
| 22 | file://0009-FF-A-v15-arm_ffa-efi-introduce-FF-A-MM-communication.patch \ |
| 23 | file://0010-FF-A-v15-arm_ffa-efi-corstone1000-enable-MM-communic.patch \ |
| 24 | file://0011-efi-corstone1000-fwu-introduce-EFI-capsule-update.patch \ |
| 25 | file://0012-arm-corstone1000-fix-unrecognized-filesystem-type.patch \ |
| 26 | file://0013-efi_loader-corstone1000-remove-guid-check-from-corst.patch \ |
| 27 | file://0014-efi_loader-populate-ESRT-table-if-EFI_ESRT-config-op.patch \ |
| 28 | file://0015-efi_firmware-add-get_image_info-for-corstone1000.patch \ |
| 29 | file://0016-efi_loader-fix-null-pointer-exception-with-get_image.patch \ |
| 30 | file://0017-arm-corstone1000-add-mmc-for-fvp.patch \ |
| 31 | file://0018-corstone1000-add-compressed-kernel-support.patch \ |
| 32 | file://0019-Introduce-external-sys-driver-to-device-tree.patch \ |
| 33 | file://0020-Add-mhu-and-rpmsg-client-to-u-boot-device-tree.patch \ |
| 34 | file://0021-arm-corstone1000-esrt-support.patch \ |
| 35 | file://0022-corstone1000-enable-distro-booting-command.patch \ |
| 36 | file://0023-corstone1000-add-fwu-metadata-store-info.patch \ |
| 37 | file://0024-fwu_metadata-make-sure-structures-are-packed.patch \ |
| 38 | file://0025-corstone1000-add-boot-index.patch \ |
| 39 | file://0026-corstone1000-adjust-boot-bank-and-kernel-location.patch \ |
| 40 | file://0027-corstone1000-add-nvmxip-fwu-mdata-and-gpt-options.patch \ |
| 41 | file://0028-nvmxip-move-header-to-include.patch \ |
| 42 | file://0029-corstone1000-set-kernel_addr-based-on-boot_idx.patch \ |
| 43 | file://0030-corstone1000-boot-index-from-active.patch \ |
| 44 | file://0031-corstone1000-enable-PSCI-reset.patch \ |
| 45 | file://0032-Enable-EFI-set-get-time-services.patch \ |
Andrew Geissler | 2edf064 | 2023-09-11 08:24:07 -0400 | [diff] [blame] | 46 | file://0033-corstone1000-detect-inflated-kernel-size.patch \ |
| 47 | file://0034-corstone1000-ESRT-add-unique-firmware-GUID.patch \ |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 48 | file://0035-dt-Provide-a-way-to-remove-non-compliant-nodes-and-p.patch \ |
| 49 | file://0036-bootefi-Call-the-EVT_FT_FIXUP-event-handler.patch \ |
| 50 | file://0037-corstone1000-purge-U-Boot-specific-DT-nodes.patch \ |
| 51 | file://0038-corstone1000-add-signature-device-tree-overlay.patch \ |
| 52 | file://0039-corstone1000-enable-authenticated-capsule-config.patch \ |
| 53 | file://0040-corstone1000-introduce-EFI-authenticated-capsule-upd.patch \ |
Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 54 | " |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 55 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 56 | do_configure:append:corstone1000(){ |
| 57 | openssl req -x509 -sha256 -newkey rsa:2048 -subj /CN=CRT/ -keyout ${B}/CRT.key -out ${B}/CRT.crt -nodes -days 365 |
| 58 | cert-to-efi-sig-list ${B}/CRT.crt ${B}/corstone1000_defconfig/CRT.esl |
| 59 | } |
| 60 | |
| 61 | do_install:append:corstone1000() { |
| 62 | install -D -p -m 0644 ${B}/CRT.crt ${DEPLOY_DIR_IMAGE}/corstone1000_capsule_cert.crt |
| 63 | install -D -p -m 0644 ${B}/CRT.key ${DEPLOY_DIR_IMAGE}/corstone1000_capsule_key.key |
| 64 | } |
| 65 | |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 66 | # |
| 67 | # FVP BASE |
| 68 | # |
Andrew Geissler | 2daf84b | 2023-03-31 09:57:23 -0500 | [diff] [blame] | 69 | SRC_URI:append:fvp-base = " file://bootargs.cfg \ |
| 70 | file://0001-Revert-vexpress64-pick-DRAM-size-from-DT.patch \ |
| 71 | " |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 72 | # |
| 73 | # Juno Machines |
| 74 | # |
Patrick Williams | b9af875 | 2023-01-30 13:28:01 -0600 | [diff] [blame] | 75 | SRC_URI:append:juno = " file://0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch" |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 76 | |
| 77 | |
| 78 | # |
| 79 | # TC0 and TC1 MACHINES |
| 80 | # |
| 81 | SRC_URI:append:tc = " \ |
| 82 | file://bootargs.cfg \ |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 83 | " |