Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'. |
| 2 | # The following is the difference between the old and the new license text. |
| 3 | # Please update the LICENSE value if needed, and summarize the changes in |
| 4 | # the commit message via 'License-Update:' tag. |
| 5 | # (example: 'License-Update: copyright years updated.') |
| 6 | # |
| 7 | # The changes: |
| 8 | # |
| 9 | # --- COPYING |
| 10 | # +++ COPYING |
| 11 | # @@ -2,7 +2,8 @@ |
| 12 | # Version 2, June 1991 |
| 13 | # |
| 14 | # Copyright (C) 1989, 1991 Free Software Foundation, Inc. |
| 15 | # - 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA |
| 16 | # + 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA |
| 17 | # + |
| 18 | # Everyone is permitted to copy and distribute verbatim copies |
| 19 | # of this license document, but changing it is not allowed. |
| 20 | # |
| 21 | # |
| 22 | # |
| 23 | |
| 24 | SUMMARY = "Alsa OSS Compatibility Package" |
| 25 | SECTION = "libs/multimedia" |
| 26 | LICENSE = "GPLv2" |
| 27 | LIC_FILES_CHKSUM = "file://COPYING;md5=ed055b4eff93da784176a01582e6ec1a" |
| 28 | DEPENDS = "alsa-lib" |
| 29 | |
| 30 | SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2 \ |
| 31 | file://libio.patch \ |
| 32 | " |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame^] | 33 | SRC_URI[md5sum] = "9ec4bb783fdce19032aace086d65d874" |
| 34 | SRC_URI[sha256sum] = "64adcef5927e848d2e024e64c4bf85b6f395964d9974ec61905ae4cb8d35d68e" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | |
| 36 | inherit autotools |
| 37 | |
| 38 | LEAD_SONAME = "libaoss.so.0" |
| 39 | |
| 40 | do_configure_prepend () { |
| 41 | touch NEWS README AUTHORS ChangeLog |
| 42 | sed -i "s/libaoss.so/${LEAD_SONAME}/" ${S}/alsa/aoss.in |
| 43 | } |
| 44 | |
| 45 | # http://errors.yoctoproject.org/Errors/Details/186961/ |
| 46 | EXCLUDE_FROM_WORLD_libc-musl = "1" |