Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The Cairo 2D vector graphics library" |
| 2 | DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \ |
| 3 | vector-based rendering for multiple target backends. Paths consist \ |
| 4 | of line segments and cubic splines and can be rendered at any width \ |
| 5 | with various join and cap styles. All colors may be specified with \ |
| 6 | optional translucence (opacity/alpha) and combined using the \ |
| 7 | extended Porter/Duff compositing algebra as found in the X Render \ |
| 8 | Extension." |
| 9 | HOMEPAGE = "http://cairographics.org" |
| 10 | BUGTRACKER = "http://bugs.freedesktop.org" |
| 11 | SECTION = "libs" |
| 12 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 13 | LICENSE = "(MPL-1.1 | LGPLv2.1) & GPLv3+" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | LICENSE:${PN} = "MPL-1.1 | LGPLv2.1" |
| 15 | LICENSE:${PN}-dev = "MPL-1.1 | LGPLv2.1" |
| 16 | LICENSE:${PN}-doc = "MPL-1.1 | LGPLv2.1" |
| 17 | LICENSE:${PN}-gobject = "MPL-1.1 | LGPLv2.1" |
| 18 | LICENSE:${PN}-script-interpreter = "MPL-1.1 | LGPLv2.1" |
| 19 | LICENSE:${PN}-perf-utils = "GPLv3+" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | |
| 21 | LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77" |
| 22 | |
| 23 | DEPENDS = "fontconfig glib-2.0 libpng pixman zlib" |
| 24 | |
| 25 | SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz \ |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 26 | file://cairo-get_bitmap_surface-bsc1036789-CVE-2017-7475.diff \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | file://CVE-2018-19876.patch \ |
| 28 | file://CVE-2019-6461.patch \ |
| 29 | file://CVE-2019-6462.patch \ |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 30 | file://CVE-2020-35492.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | SRC_URI[md5sum] = "f19e0353828269c22bd72e271243a552" |
| 34 | SRC_URI[sha256sum] = "5e7b29b3f113ef870d1e3ecf8adf21f923396401604bda16d44be45e66052331" |
| 35 | |
| 36 | inherit autotools pkgconfig upstream-version-is-even gtk-doc multilib_script |
| 37 | |
| 38 | MULTILIB_SCRIPTS = "${PN}-perf-utils:${bindir}/cairo-trace" |
| 39 | |
| 40 | X11DEPENDS = "virtual/libx11 libsm libxrender libxext" |
| 41 | |
| 42 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \ |
| 43 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)} \ |
| 45 | trace" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | PACKAGECONFIG:class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}" |
| 47 | PACKAGECONFIG:class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 48 | |
| 49 | PACKAGECONFIG[x11] = "--with-x=yes -enable-xlib,--with-x=no --disable-xlib,${X11DEPENDS}" |
| 50 | PACKAGECONFIG[xcb] = "--enable-xcb,--disable-xcb,libxcb" |
| 51 | PACKAGECONFIG[directfb] = "--enable-directfb=yes,,directfb" |
| 52 | PACKAGECONFIG[valgrind] = "--enable-valgrind=yes,--disable-valgrind,valgrind" |
| 53 | PACKAGECONFIG[egl] = "--enable-egl=yes,--disable-egl,virtual/egl" |
| 54 | PACKAGECONFIG[glesv2] = "--enable-glesv2,--disable-glesv2,virtual/libgles2" |
| 55 | PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 56 | PACKAGECONFIG[trace] = "--enable-trace,--disable-trace" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 57 | |
| 58 | EXTRA_OECONF += " \ |
| 59 | ${@bb.utils.contains('TARGET_FPU', 'soft', '--disable-some-floating-point', '', d)} \ |
| 60 | --enable-tee \ |
| 61 | " |
| 62 | |
| 63 | # We don't depend on binutils so we need to disable this |
| 64 | export ac_cv_lib_bfd_bfd_openr="no" |
| 65 | # Ensure we don't depend on LZO |
| 66 | export ac_cv_lib_lzo2_lzo2a_decompress="no" |
| 67 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 68 | do_install:append () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 69 | rm -rf ${D}${bindir}/cairo-sphinx |
| 70 | rm -rf ${D}${libdir}/cairo/cairo-fdr* |
| 71 | rm -rf ${D}${libdir}/cairo/cairo-sphinx* |
| 72 | rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr* |
| 73 | rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx* |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 74 | [ ! -d ${D}${bindir} ] || |
| 75 | rmdir -p --ignore-fail-on-non-empty ${D}${bindir} |
| 76 | [ ! -d ${D}${libdir}/cairo ] || |
| 77 | rmdir -p --ignore-fail-on-non-empty ${D}${libdir}/cairo |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 78 | } |
| 79 | |
| 80 | PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils" |
| 81 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 82 | SUMMARY:cairo-gobject = "The Cairo library GObject wrapper library" |
| 83 | DESCRIPTION:cairo-gobject = "A GObject wrapper library for the Cairo API." |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 84 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 85 | SUMMARY:cairo-script-interpreter = "The Cairo library script interpreter" |
| 86 | DESCRIPTION:cairo-script-interpreter = "The Cairo script interpreter implements \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 87 | CairoScript. CairoScript is used by tracing utilities to enable the ability \ |
| 88 | to replay rendering." |
| 89 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 90 | DESCRIPTION:cairo-perf-utils = "The Cairo library performance utilities" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 91 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 92 | FILES:${PN} = "${libdir}/libcairo.so.*" |
| 93 | FILES:${PN}-gobject = "${libdir}/libcairo-gobject.so.*" |
| 94 | FILES:${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*" |
| 95 | FILES:${PN}-perf-utils = "${bindir}/cairo-trace* ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 96 | |
| 97 | BBCLASSEXTEND = "native nativesdk" |
| 98 | |
| 99 | UPSTREAM_CHECK_REGEX = "cairo-(?P<pver>\d+(\.\d+)+).tar.xz" |