Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "cui/gui tool for tuning of running processes" |
| 2 | HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Tuna" |
| 3 | LICENSE = "GPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" |
| 5 | |
| 6 | SRC_URI = "git://git.kernel.org/pub/scm/utils/tuna/tuna.git;branch=main" |
| 7 | |
| 8 | SRCREV = "0681906e75e1c8166126bbfc2f3055e7507bfcb5" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | python3-io \ |
| 14 | python3-linux-procfs \ |
| 15 | python3-logging \ |
| 16 | python3-six \ |
| 17 | " |
| 18 | |
| 19 | inherit setuptools3 |
| 20 | |
| 21 | do_install:append() { |
| 22 | install -m 0755 -d ${D}${bindir} |
| 23 | install -m 0755 ${S}/tuna-cmd.py ${D}${bindir}/tuna |
| 24 | } |