Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "udisks provides dbus interfaces for disks and storage devices" |
| 2 | LICENSE = "GPLv2+ & LGPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=dd79f6dbbffdbc8e86b086a8f0c0ef43" |
| 4 | |
| 5 | DEPENDS = " \ |
| 6 | acl \ |
| 7 | libatasmart \ |
| 8 | polkit \ |
| 9 | libgudev \ |
| 10 | dbus-glib \ |
| 11 | glib-2.0 \ |
| 12 | libblockdev \ |
| 13 | libxslt-native \ |
| 14 | " |
| 15 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 16 | |
| 17 | RDEPENDS_${PN} = "acl" |
| 18 | |
| 19 | SRC_URI = " \ |
| 20 | git://github.com/storaged-project/udisks.git;branch=master \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 21 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 22 | PV = "2.8.4+git${SRCREV}" |
| 23 | SRCREV = "db5f487345da2eaa87976450ea51c2c465d9b82e" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | CVE_PRODUCT = "udisks" |
| 27 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 28 | inherit autotools systemd gtk-doc gobject-introspection gettext features_check |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | |
| 30 | REQUIRED_DISTRO_FEATURES = "polkit" |
| 31 | |
| 32 | EXTRA_OECONF = "--disable-man --disable-gtk-doc" |
| 33 | |
| 34 | do_configure_prepend() { |
| 35 | # | configure.ac:656: error: required file 'build-aux/config.rpath' not found |
| 36 | mkdir -p ${S}/build-aux |
| 37 | touch ${S}/build-aux/config.rpath |
| 38 | } |
| 39 | |
| 40 | FILES_${PN} += " \ |
| 41 | ${datadir}/dbus-1/ \ |
| 42 | ${datadir}/polkit-1 \ |
| 43 | ${datadir}/bash-completion \ |
| 44 | ${libdir}/polkit-1/extensions/*.so \ |
| 45 | ${nonarch_base_libdir}/udev/* \ |
| 46 | ${exec_prefix}${nonarch_base_libdir}/udisks2/* \ |
| 47 | ${systemd_system_unitdir} \ |
| 48 | " |
| 49 | |
| 50 | PACKAGES =+ "${PN}-libs" |
| 51 | FILES_${PN}-libs = "${libdir}/lib*${SOLIBS}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 52 | FILES_${PN} += "${nonarch_libdir}/tmpfiles.d" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 53 | |
| 54 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" |
| 55 | SYSTEMD_AUTO_ENABLE = "disable" |