Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" |
| 2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" |
| 4 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 12 | DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ |
| 15 | file://enum-conversion.patch \ |
| 16 | " |
| 17 | SRC_URI[md5sum] = "06488186c7dd53f8104183b86f7a1568" |
| 18 | SRC_URI[sha256sum] = "cdd5b4cb1e4d7643643a28ccbfc4bb354bfa9cb89a77ea160ebdf7926171c668" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/ModemManager-${PV}" |
| 21 | |
| 22 | PACKAGECONFIG ??= "mbim qmi polkit \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 23 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | " |
| 25 | |
| 26 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," |
| 27 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" |
| 28 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. |
| 29 | PACKAGECONFIG[mbim] = "--with-mbim,--enable-mbim=no,libmbim" |
| 30 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. |
| 31 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" |
| 32 | |
| 33 | FILES_${PN} += " \ |
| 34 | ${datadir}/icons \ |
| 35 | ${datadir}/polkit-1 \ |
| 36 | ${datadir}/dbus-1 \ |
| 37 | ${libdir}/ModemManager \ |
| 38 | ${systemd_unitdir}/system \ |
| 39 | " |
| 40 | |
| 41 | FILES_${PN}-dev += " \ |
| 42 | ${libdir}/ModemManager/*.la \ |
| 43 | " |
| 44 | |
| 45 | FILES_${PN}-staticdev += " \ |
| 46 | ${libdir}/ModemManager/*.a \ |
| 47 | " |
| 48 | |
| 49 | FILES_${PN}-dbg += "${libdir}/ModemManager/.debug" |
| 50 | |
| 51 | SYSTEMD_SERVICE_${PN} = "ModemManager.service" |