Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame^] | 1 | SUMMARY = "A small tool to read/write memory" |
| 2 | LICENSE = "GPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | DEPENDS += "python3 python3-pybind11" |
| 6 | |
| 7 | PV .= "+git${SRCPV}" |
| 8 | |
| 9 | SRCREV_rwmem = "cc296c5366a35a4c4271cfa3cc9831f6f34bfd9d" |
| 10 | SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109" |
| 11 | |
| 12 | SRCREV_FORMAT = "rwmem_inih" |
| 13 | |
| 14 | SRC_URI = " \ |
| 15 | git://github.com/tomba/rwmem.git;protocol=https;name=rwmem \ |
| 16 | git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \ |
| 17 | " |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake pkgconfig |
| 22 | |
| 23 | do_install() { |
| 24 | install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem |
| 25 | install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a |
| 26 | } |