Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | require gst-plugins.inc |
| 2 | |
| 3 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 5 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f \ |
| 6 | file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe" |
| 7 | |
| 8 | PR = "r8" |
| 9 | |
| 10 | PACKAGECONFIG ?= "jpeg v4l \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | " |
| 13 | PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio" |
| 14 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" |
| 15 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| 16 | PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack" |
| 17 | PACKAGECONFIG[gdkpixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf" |
| 18 | PACKAGECONFIG[v4l] = "--enable-gst_v4l2 --with-gudev,--disable-gst_v4l2 --without-gudev,libgudev" |
| 19 | # sub-feature of v4l, but control separately since libv4l is not part of oe-core |
| 20 | PACKAGECONFIG[libv4l] = "--with-libv4l2,--without-libv4l2,libv4l" |
| 21 | PACKAGECONFIG[bzip2] = "--enable-bz2,--disable-bz2,bzip2" |
| 22 | PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc" |
| 23 | PACKAGECONFIG[x11] = "--enable-x,--disable-x,virtual/libx11 libxfixes libxdamage" |
| 24 | PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libraw1394 libiec61883 libavc1394" |
| 25 | |
| 26 | DEPENDS += "gst-plugins-base gconf cairo libpng zlib libid3tag flac \ |
| 27 | speex libsoup-2.4 libcap" |
| 28 | |
| 29 | inherit gettext gconf |
| 30 | |
| 31 | SRC_URI += "file://0001-v4l2-fix-build-with-recent-kernels-the-v4l2_buffer-i.patch \ |
| 32 | file://0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch \ |
| 33 | file://0407-mulawdec-fix-integer-overrun.patch \ |
| 34 | " |
| 35 | EXTRA_OECONF += "--disable-aalib --disable-esd --disable-shout2 --disable-libcaca --disable-hal \ |
| 36 | --disable-examples --disable-taglib" |
| 37 | |
| 38 | do_configure_prepend() { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 39 | # This m4 file contains nastiness which conflicts with libtool 2.2.2 |
| 40 | rm ${S}/m4/lib-link.m4 || true |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 41 | } |
| 42 | |
| 43 | SRC_URI[md5sum] = "24f98a294a2b521e1b29412bdadae2e6" |
| 44 | SRC_URI[sha256sum] = "7e27840e40a7932ef2dc032d7201f9f41afcaf0b437daf5d1d44dc96d9e35ac6" |
| 45 | |
| 46 | FILES_${PN}-gconfelements += "${sysconfdir}/gconf/schemas/gstreamer-0.10.schemas" |
| 47 | FILES_${PN}-equalizer += "${datadir}/gstreamer-0.10/presets/*.prs" |