Brad Bishop | 7fe43db | 2016-04-15 09:53:23 -0400 | [diff] [blame] | 1 | SUMMARY = "Inventory upload" |
| 2 | DESCRIPTION = "Inventory upload." |
| 3 | HOMEPAGE = "http://github.com/openbmc/openpower-inventory-upload" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit allarch |
| 9 | inherit setuptools |
Brad Bishop | 1d525fa | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 10 | inherit obmc-phosphor-systemd |
Brad Bishop | 7fe43db | 2016-04-15 09:53:23 -0400 | [diff] [blame] | 11 | |
| 12 | RDEPENDS_${PN} += " \ |
Brad Bishop | f441ae3 | 2016-05-03 10:51:48 -0400 | [diff] [blame] | 13 | python-dbus \ |
| 14 | python-pygobject \ |
Brad Bishop | 7fe43db | 2016-04-15 09:53:23 -0400 | [diff] [blame] | 15 | pyphosphor \ |
| 16 | dtc \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI += "git://github.com/openbmc/openpower-inventory-upload" |
| 20 | |
Andrew Geissler | 910303a | 2018-05-21 21:15:03 -0500 | [diff] [blame] | 21 | SRCREV = "c115852fb5aa0890373d8c2dfca9b9f7b1e06527" |
Brad Bishop | 7fe43db | 2016-04-15 09:53:23 -0400 | [diff] [blame] | 22 | |
| 23 | S = "${WORKDIR}/git" |
Brad Bishop | 1d525fa | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 24 | |
| 25 | TMPL = "op-inventory-upload@.service" |
| 26 | INSTFMT = "op-inventory-upload@{0}.service" |
Josh D. King | efb04a1 | 2017-04-06 15:56:37 -0500 | [diff] [blame] | 27 | TGTFMT = "obmc-host-start@{0}.target" |
Brad Bishop | 1d525fa | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 28 | FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}" |
| 29 | |
| 30 | SYSTEMD_SERVICE_${PN} += "${TMPL}" |
| 31 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |