Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "interface to seccomp filtering mechanism" |
| 2 | DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp." |
| 3 | SECTION = "security" |
| 4 | LICENSE = "LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f" |
| 6 | |
| 7 | SRCREV = "74b190e1aa05f07da0c61fb9a30dbc9c18ce2c9d" |
| 8 | |
| 9 | SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.3 \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit autotools-brokensep pkgconfig ptest |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python" |
| 19 | |
| 20 | do_compile_ptest() { |
| 21 | oe_runmake -C tests check-build |
| 22 | } |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | install -d ${D}${PTEST_PATH}/tools |
| 27 | for file in $(find tests/* -executable -type f); do |
| 28 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 29 | done |
| 30 | for file in $(find tests/*.tests -type f); do |
| 31 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 32 | done |
| 33 | for file in $(find tools/* -executable -type f); do |
| 34 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 35 | done |
| 36 | } |
| 37 | |
| 38 | FILES_${PN} = "${bindir} ${libdir}/${PN}.so*" |
| 39 | FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug" |
| 40 | |
| 41 | RDEPENDS_${PN} = "bash" |
| 42 | RDEPENDS_${PN}-ptest = "bash" |