Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "system security services daemon" |
| 2 | DESCRIPTION = "SSSD is a system security services daemon" |
| 3 | HOMEPAGE = "https://fedorahosted.org/sssd/" |
| 4 | SECTION = "base" |
| 5 | LICENSE = "GPLv3+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 7 | |
| 8 | DEPENDS = "openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive" |
| 9 | DEPENDS += "libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent" |
| 10 | |
| 11 | SRC_URI = "https://releases.pagure.org/SSSD/${BPN}/${BP}.tar.gz\ |
| 12 | file://sssd.conf " |
| 13 | |
| 14 | SRC_URI[md5sum] = "f721ace2ebfa6744cfea55e3ecd2d82f" |
| 15 | SRC_URI[sha256sum] = "c581a6e5365cef87fca419c0c9563cf15eadbb682863d648d85ffcded7a3940f" |
| 16 | |
| 17 | inherit autotools pkgconfig gettext update-rc.d python-dir distro_features_check |
| 18 | |
| 19 | REQUIRED_DISTRO_FEATURES = "pam" |
| 20 | |
| 21 | CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \ |
| 22 | ac_cv_path_NSUPDATE=${bindir} \ |
| 23 | ac_cv_path_PYTHON2=${PYTHON_DIR} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \ |
| 24 | " |
| 25 | |
| 26 | PACKAGECONFIG ?="nss nscd" |
| 27 | PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" |
| 28 | |
| 29 | PACKAGECONFIG[ssh] = "--with-ssh, --with-ssh=no, " |
| 30 | PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba" |
| 31 | PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux" |
| 32 | PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no" |
| 33 | PACKAGECONFIG[python2] = "--with-python2-bindings, --without-python2-bindings" |
| 34 | PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings" |
| 35 | PACKAGECONFIG[nss] = "--with-crypto=nss, ,nss," |
| 36 | PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto" |
| 37 | PACKAGECONFIG[nscd] = "--with-nscd=${sbindir}, --with-nscd=no " |
| 38 | PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl" |
| 39 | PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/, --with-systemdunitdir=" |
| 40 | PACKAGECONFIG[http] = "--with-secrets, --without-secrets, apache2" |
| 41 | PACKAGECONFIG[curl] = "--with-secrets --with-kcm, --without-secrets --without-kcm, curl" |
| 42 | |
| 43 | EXTRA_OECONF += "--disable-cifs-idmap-plugin --without-nfsv4-idmapd-plugin --without-ipa-getkeytab" |
| 44 | |
| 45 | do_configure_prepend() { |
| 46 | mkdir -p ${AUTOTOOLS_AUXDIR}/build |
| 47 | cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/build/ |
| 48 | |
| 49 | # libresove has host path, remove it |
| 50 | sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4 |
| 51 | } |
| 52 | |
| 53 | do_install () { |
| 54 | oe_runmake install DESTDIR="${D}" |
| 55 | rmdir --ignore-fail-on-non-empty "${D}/${bindir}" |
| 56 | install -d ${D}/${sysconfdir}/${BPN} |
| 57 | install -m 600 ${WORKDIR}/${BPN}.conf ${D}/${sysconfdir}/${BPN} |
| 58 | } |
| 59 | |
| 60 | CONFFILES_${PN} = "${sysconfdir}/${BPN}/${BPN}.conf" |
| 61 | |
| 62 | INITSCRIPT_NAME = "sssd" |
| 63 | INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ." |
| 64 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" |
| 65 | SYSTEMD_AUTO_ENABLE = "disable" |
| 66 | |
| 67 | FILES_${PN} += "${libdir} ${datadir} /run ${libdir}/*.so* " |
| 68 | FILES_${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la" |
| 69 | |
| 70 | # The package contains symlinks that trip up insane |
| 71 | INSANE_SKIP_${PN} = "dev-so" |
| 72 | |
| 73 | RDEPENDS_${PN} += "bind dbus" |