Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "in-depth comparison of files, archives, and directories" |
| 2 | DESCRIPTION = "Tries to get to the bottom of what makes files or directories \ |
| 3 | different. It will recursively unpack archives of many kinds and transform \ |
| 4 | various binary formats into more human-readable form to compare them. \ |
| 5 | It can compare two tarballs, ISO images, or PDF just as easily." |
| 6 | HOMEPAGE = "https://diffoscope.org/" |
| 7 | BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues" |
| 8 | LICENSE = "GPL-3.0-or-later" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 10 | |
| 11 | PYPI_PACKAGE = "diffoscope" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | SRC_URI[sha256sum] = "2c5c0ac1159eefce158154849fe67f0f527dffc5295bfd3ca1aef14962ffcbcb" |
| 16 | |
| 17 | RDEPENDS:${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm" |
| 18 | |
| 19 | # Dependencies don't build for musl |
| 20 | COMPATIBLE_HOST:libc-musl = 'null' |
| 21 | |
| 22 | do_install:append:class-native() { |
| 23 | create_wrapper ${D}${bindir}/diffoscope \ |
| 24 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \ |
| 25 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ |
| 26 | LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \ |
| 27 | RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native" |