Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Mobile IPv6 and NEMO for Linux" |
| 2 | DESCRIPTION = "UMIP is an open source implementation of Mobile IPv6 and NEMO \ |
| 3 | Basic Support for Linux. It is released under the GPLv2 license. It supports \ |
| 4 | the following IETF RFC: RFC6275 (Mobile IPv6), RFC3963 (NEMO), RFC3776 and \ |
| 5 | RFC4877 (IPsec and IKEv2)." |
| 6 | HOMEPAGE = "http://umip.org/" |
| 7 | SECTION = "System Environment/Base" |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33" |
| 10 | DEPENDS = "openssl ipsec-tools radvd indent-native bison-native" |
| 11 | |
| 12 | SRC_URI = "git://git.umip.org/umip/umip.git \ |
| 13 | file://add-dependency-to-support-parallel-compilation.patch \ |
| 14 | file://mip6d \ |
| 15 | file://mip6d.service \ |
| 16 | file://0001-Add-format-string-to-fprintf-call.patch \ |
| 17 | file://0001-replace-SIGCLD-with-SIGCHLD-and-include-sys-types.h.patch \ |
| 18 | file://0002-replace-PTHREAD_MUTEX_FAST_NP-with-PTHREAD_MUTEX_NOR.patch \ |
| 19 | file://0001-support-openssl-1.1.x.patch \ |
| 20 | " |
| 21 | SRCREV = "cbd441c5db719db554ff2b4fcb02fef88ae2f791" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | EXTRA_OECONF = "--enable-vt" |
| 26 | |
| 27 | inherit autotools-brokensep systemd update-rc.d |
| 28 | |
| 29 | INITSCRIPT_NAME = "mip6d" |
| 30 | INITSCRIPT_PARAMS = "start 64 . stop 36 0 1 2 3 4 5 6 ." |
| 31 | |
| 32 | SYSTEMD_SERVICE_${PN} = "mip6d.service" |
| 33 | SYSTEMD_AUTO_ENABLE = "disable" |
| 34 | |
| 35 | do_install_append() { |
| 36 | install -D -m 0755 ${WORKDIR}/mip6d ${D}${sysconfdir}/init.d/mip6d |
| 37 | install -D -m 0644 ${WORKDIR}/mip6d.service ${D}${systemd_system_unitdir}/mip6d.service |
| 38 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 39 | -e 's,@SBINDIR@,${sbindir},g' \ |
| 40 | ${D}${systemd_system_unitdir}/mip6d.service |
| 41 | } |
| 42 | |
| 43 | RRECOMMENDS_${PN} = "kernel-module-mip6 kernel-module-ipv6" |