Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "A text-based user interface plugin of dnf for user to manage packages. " |
| 2 | LICENSE = "GPLv2" |
| 3 | |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 5 | |
| 6 | SRC_URI = "git://github.com/ubinux/dnf-plugin-tui.git;branch=master " |
| 7 | SRCREV = "31d6866d5eda02be9a6bfb1fca9e9095b12eecd1" |
| 8 | PV = "1.0" |
| 9 | |
| 10 | SRC_URI_append_class-target = "file://oe-remote.repo.sample" |
| 11 | |
| 12 | inherit distutils3-base |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_install_append() { |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 17 | install -d ${D}${datadir}/dnf |
| 18 | install -m 0755 ${S}/samples/* ${D}${datadir}/dnf |
| 19 | install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg |
| 20 | install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg |
| 21 | for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do |
| 22 | install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins |
| 23 | done |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 24 | } |
| 25 | |
| 26 | do_install_append_class-target() { |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 27 | install -d ${D}${sysconfdir}/yum.repos.d |
| 28 | install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 29 | } |
| 30 | |
| 31 | FILES_${PN} += "${datadir}/dnf" |
| 32 | |
| 33 | RDEPENDS_${PN} += " \ |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 34 | bash \ |
| 35 | dnf \ |
| 36 | libnewt-python \ |
| 37 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 38 | |
| 39 | BBCLASSEXTEND = "nativesdk" |