Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "3D graphics and compute API common loader" |
| 2 | DESCRIPTION = "Vulkan is a new generation graphics and compute API \ |
| 3 | that provides efficient access to modern GPUs. These packages \ |
| 4 | provide only the common vendor-agnostic library loader, headers and \ |
| 5 | the vulkaninfo utility." |
| 6 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 7 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Loader" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Apache-2.0" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7dbefed23242760aa3475ee42801c5ac" |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 12 | SRC_URI = "git://github.com/KhronosGroup/Vulkan-Loader.git;branch=sdk-1.2.135" |
| 13 | SRCREV = "86429d9e7f3542e88fb98ffa7d8a82c10c9828ac" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | REQUIRED_DISTRO_FEATURES = "vulkan" |
| 18 | |
| 19 | inherit cmake features_check |
| 20 | ANY_OF_DISTRO_FEATURES = "x11 wayland" |
| 21 | |
| 22 | DEPENDS += "vulkan-headers" |
| 23 | |
| 24 | EXTRA_OECMAKE = "\ |
| 25 | -DBUILD_TESTS=OFF \ |
| 26 | -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ |
| 27 | -DASSEMBLER_WORKS=FALSE \ |
| 28 | " |
| 29 | |
| 30 | # must choose x11 or wayland or both |
| 31 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 32 | |
| 33 | PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr" |
| 34 | PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland" |
| 35 | |
| 36 | RRECOMMENDS_${PN} = "mesa-vulkan-drivers" |
| 37 | |
| 38 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |