Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Exports your X session or FrameBuffer(fbdev) on-the-fly via VNC" |
| 2 | HOMEPAGE = "http://www.karlrunge.com/x11vnc/" |
| 3 | |
| 4 | SECTION = "x11/utils" |
| 5 | AUTHOR = "Karl Runge" |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://src/x11vnc.h;endline=31;md5=e871a2ad004776794b616822dcab6314" |
| 9 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 10 | SRCREV = "87cd0530f438372dda3c70bb491a6fd19f09acc2" |
| 11 | PV .= "+git${SRCPV}" |
| 12 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 13 | SRC_URI = "git://github.com/LibVNC/x11vnc \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | file://starting-fix.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 15 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 16 | S = "${WORKDIR}/git" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | |
| 18 | DEPENDS = "\ |
| 19 | jpeg \ |
| 20 | libtasn1 \ |
| 21 | libvncserver \ |
| 22 | openssl \ |
| 23 | p11-kit \ |
| 24 | zlib \ |
| 25 | " |
| 26 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 27 | inherit pkgconfig autotools features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
| 29 | ANY_OF_DISTRO_FEATURES = "x11 fbdev" |
| 30 | |
| 31 | PACKAGECONFIG ??= "\ |
| 32 | ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \ |
| 33 | ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \ |
| 34 | " |
| 35 | |
| 36 | PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi" |
| 37 | PACKAGECONFIG[xinerama] = "--with-xinerama,--without-xinerama,libxinerama" |
| 38 | PACKAGECONFIG[x11] = "--with-x,--without-x, libxdamage libxext libxfixes libxrandr libxtst virtual/libx11" |
| 39 | |
| 40 | RRECOMMENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'fbdev', 'kernel-module-uinput', '', d)}" |