blob: 12e9f88201870065c1818dad75a12815ea7dd1c4 [file] [log] [blame]
Andrew Jeffery8c8fb8b2022-01-27 10:19:17 +10301FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3SRC_URI:append:p10bmc = " file://a3.json file://keys/"
4
Andrew Jefferyb1642002022-08-08 21:45:34 +09305OTPTOOL_CONFIGS:p10bmc = "${WORKDIR}/a3.json"
Andrew Jeffery8c8fb8b2022-01-27 10:19:17 +10306OTPTOOL_KEY_DIR:p10bmc = "${WORKDIR}/keys/"
7
8# !!! Do not copy p10bmc's use of little-endian key ordering !!!
9#
10# The prefered order for production silicon is big-endian. Little-endian is necessary for p10bmc
11# platforms due to development history involving pre-production AST2600 silicon. More discussion
12# here:
13#
14# https://gerrit.openbmc-project.xyz/c/openbmc/openbmc/+/50716
15SOCSEC_SIGN_EXTRA_OPTS = "--rsa_key_order=little"
16
17do_deploy:prepend:p10bmc() {
18 # otptool needs access to the public and private socsec signing keys in the keys/ directory
19 openssl rsa -in ${SOCSEC_SIGN_KEY} -pubout > ${WORKDIR}/keys/rsa_pub_oem_dss_key.pem
20}