Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "U-Boot libraries and tools to access environment" |
| 2 | |
| 3 | DESCRIPTION = "This package contains tools and libraries to read \ |
| 4 | and modify U-Boot environment. \ |
| 5 | It provides a hardware-independent replacement for fw_printenv/setenv utilities \ |
| 6 | provided by U-Boot" |
| 7 | |
| 8 | HOMEPAGE = "https://github.com/sbabic/libubootenv" |
| 9 | LICENSE = "LGPL-2.1-or-later" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSES/LGPL-2.1-or-later.txt;md5=4fbd65380cdd255951079008b364516c" |
| 11 | SECTION = "libs" |
| 12 | |
| 13 | SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https;branch=master" |
| 14 | SRCREV = "3f4d15e36ceb58085b08dd13f3f2788e9299877b" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake lib_package |
| 19 | |
| 20 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release" |
| 21 | |
| 22 | DEPENDS = "zlib libyaml" |
| 23 | PROVIDES += "u-boot-fw-utils" |
| 24 | RPROVIDES:${PN}-bin += "u-boot-fw-utils" |
| 25 | |
| 26 | BBCLASSEXTEND = "native" |