Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Bash Automated Testing System" |
| 2 | DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \ |
| 3 | provides a simple way to verify that the UNIX programs you write behave as expected." |
| 4 | AUTHOR = "Sam Stephenson & bats-core organization" |
| 5 | HOMEPAGE = "https://github.com/bats-core/bats-core" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b" |
| 8 | |
| 9 | SRC_URI = "git://github.com/bats-core/bats-core.git \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 10 | file://0001-install.sh-consider-multilib.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | # v1.4.1 |
| 13 | SRCREV = "54e965fa9d269c2b3ff9036d81f32bac3df0edea" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 17 | do_configure:prepend() { |
| 18 | sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats |
| 19 | sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-file |
| 20 | sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-test |
| 21 | } |
| 22 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 23 | do_install() { |
| 24 | # Just a bunch of bash scripts to install |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 25 | ${S}/install.sh ${D}${prefix} ${baselib} |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 26 | } |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | RDEPENDS:${PN} = "bash" |
| 29 | FILES:${PN} += "${libdir}/bats-core/*" |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 30 | |
| 31 | PACKAGECONFIG ??= "pretty" |
| 32 | PACKAGECONFIG[pretty] = ",,,ncurses" |