blob: e79f62ff6eecc577a71a15d7db6db69d999991b0 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "Tools of dm-thin device-mapper"
2DESCRIPTION = "A suite of tools for manipulating the metadata of the dm-thin device-mapper target."
3HOMEPAGE = "https://github.com/jthornber/thin-provisioning-tools"
4LICENSE = "GPL-3.0-only"
5SECTION = "devel"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8S = "${WORKDIR}/git"
9
10SRC_URI = " \
11 git://github.com/jthornber/thin-provisioning-tools;branch=main;protocol=https \
12 "
13SRC_URI:append:libc-musl = " file://0001-Replace-LFS-functions.patch"
14
15SRCREV = "3baa3fa3a3e4f714e6170a4152b186f0fa1d76e1"
16UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
17
18inherit cargo cargo-update-recipe-crates
19
20require ${BPN}-crates.inc
21require ${BPN}-git-crates.inc
22
23do_install:append() {
24 for tool in cache_check \
25 cache_dump \
26 cache_metadata_size \
27 cache_repair \
28 cache_restore \
29 cache_writeback \
30 thin_check \
31 thin_delta \
32 thin_dump \
33 thin_ls \
34 thin_repair \
35 thin_restore \
36 thin_rmap \
37 thin_metadata_size \
38 thin_metadata_pack \
39 thin_metadata_unpack \
40 thin_trim \
41 era_check \
42 era_dump \
43 era_invalidate \
44 era_restore; do
45 ln -sf pdata_tools ${D}${bindir}/$tool
46 done
47}