Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools of dm-thin device-mapper" |
| 2 | DESCRIPTION = "A suite of tools for manipulating the metadata of the dm-thin device-mapper target." |
| 3 | HOMEPAGE = "https://github.com/jthornber/thin-provisioning-tools" |
| 4 | LICENSE = "GPL-3.0-only" |
| 5 | SECTION = "devel" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | git://github.com/jthornber/thin-provisioning-tools;branch=main;protocol=https \ |
| 12 | " |
| 13 | SRC_URI:append:libc-musl = " file://0001-Replace-LFS-functions.patch" |
| 14 | |
| 15 | SRCREV = "3baa3fa3a3e4f714e6170a4152b186f0fa1d76e1" |
| 16 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 17 | |
| 18 | inherit cargo cargo-update-recipe-crates |
| 19 | |
| 20 | require ${BPN}-crates.inc |
| 21 | require ${BPN}-git-crates.inc |
| 22 | |
| 23 | do_install:append() { |
| 24 | for tool in cache_check \ |
| 25 | cache_dump \ |
| 26 | cache_metadata_size \ |
| 27 | cache_repair \ |
| 28 | cache_restore \ |
| 29 | cache_writeback \ |
| 30 | thin_check \ |
| 31 | thin_delta \ |
| 32 | thin_dump \ |
| 33 | thin_ls \ |
| 34 | thin_repair \ |
| 35 | thin_restore \ |
| 36 | thin_rmap \ |
| 37 | thin_metadata_size \ |
| 38 | thin_metadata_pack \ |
| 39 | thin_metadata_unpack \ |
| 40 | thin_trim \ |
| 41 | era_check \ |
| 42 | era_dump \ |
| 43 | era_invalidate \ |
| 44 | era_restore; do |
| 45 | ln -sf pdata_tools ${D}${bindir}/$tool |
| 46 | done |
| 47 | } |