blob: 55d8a2d74ee772230e12d7e8b25e3ce75da8a69e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A thin layer of graphic data types"
2HOMEPAGE = "http://ebassi.github.io/graphene/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a7d871d9e23c450c421a85bb2819f648"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8inherit gnomebase gobject-introspection gtk-doc
9
Andrew Geissler5082cc72023-09-11 08:41:39 -040010SRC_URI += "file://float-div.patch"
11
Andrew Geissler517393d2023-01-13 08:55:19 -060012SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
13
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060014# Disable neon support by default on ARM-32 platforms because of the
15# following upstream bug: https://github.com/ebassi/graphene/issues/215
Patrick Williams8e7b46e2023-05-01 14:19:06 -050016PACKAGECONFIG ?= "gobject-types ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060017
Patrick Williams8e7b46e2023-05-01 14:19:06 -050018PACKAGECONFIG[gobject-types] = "-Dgobject_types=true,-Dgobject_types=false,glib-2.0"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060019PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
20
21GIR_MESON_ENABLE_FLAG = 'enabled'
22GIR_MESON_DISABLE_FLAG = 'disabled'
Andrew Geissler517393d2023-01-13 08:55:19 -060023
24GTKDOC_MESON_OPTION = "gtk_doc"
25
26EXTRA_OEMESON = "-Dinstalled_tests=false"
27
28FILES:${PN} += "${libdir}/graphene-1.0"
29
30BBCLASSEXTEND = "native nativesdk"