blob: 4b458dedd50f18a40ee9e18bad6172da219b7387 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhinstaller/efivar"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8DEPENDS = "popt"
9DEPENDS_append_class-target = " efivar-native"
10
11inherit pkgconfig
12
13COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
14
15SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10"
16SRC_URI = "git://github.com/rhinstaller/efivar.git \
17 file://allow-multi-definitions-for-native.patch \
18 "
19SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'file://0004-fix-unknow-option-for-gold-linker.patch', '', d)} \
21 "
Brad Bishop19323692019-04-05 15:28:33 -040022
23S = "${WORKDIR}/git"
24
25do_compile_prepend() {
26 sed -i -e s:-Werror::g ${S}/gcc.specs
27}
28
29do_compile_class-native() {
30 oe_runmake -C src makeguids CC_FOR_BUILD="${BUILD_CC}"
31}
32
33do_install() {
34 oe_runmake install DESTDIR=${D}
35}
36
37do_install_class-native() {
38 install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids
39}
40
41BBCLASSEXTEND = "native"
42
Brad Bishopc342db32019-05-15 21:57:59 -040043RRECOMMENDS_${PN}_class-target = "kernel-module-efivarfs"