Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools to manipulate UEFI variables" |
| 2 | DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility" |
| 3 | HOMEPAGE = "https://github.com/rhinstaller/efivar" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" |
| 7 | |
| 8 | DEPENDS = "popt" |
| 9 | DEPENDS_append_class-target = " efivar-native" |
| 10 | |
| 11 | inherit pkgconfig |
| 12 | |
| 13 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 14 | |
| 15 | SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10" |
| 16 | SRC_URI = "git://github.com/rhinstaller/efivar.git \ |
| 17 | file://allow-multi-definitions-for-native.patch \ |
| 18 | " |
| 19 | SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \ |
| 20 | ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'file://0004-fix-unknow-option-for-gold-linker.patch', '', d)} \ |
| 21 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | do_compile_prepend() { |
| 26 | sed -i -e s:-Werror::g ${S}/gcc.specs |
| 27 | } |
| 28 | |
| 29 | do_compile_class-native() { |
| 30 | oe_runmake -C src makeguids CC_FOR_BUILD="${BUILD_CC}" |
| 31 | } |
| 32 | |
| 33 | do_install() { |
| 34 | oe_runmake install DESTDIR=${D} |
| 35 | } |
| 36 | |
| 37 | do_install_class-native() { |
| 38 | install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids |
| 39 | } |
| 40 | |
| 41 | BBCLASSEXTEND = "native" |
| 42 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 43 | RRECOMMENDS_${PN}_class-target = "kernel-module-efivarfs" |