blob: 47f1267ab6b1ed1ad5ac57219b41e32bdb1f3a8d [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001HOMEPAGE = "http://www.gevent.org"
2SUMMARY = "A coroutine-based Python networking library"
3DESCRIPTION = "\
4 gevent is a coroutine-based Python networking library that uses greenlet \
5 to provide a high-level synchronous API on top of the libevent event \
6 loop. \
7 "
8SECTION = "devel/python"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2"
11DEPENDS += "python-greenlet libevent"
12RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re"
13
14SRCNAME = "gevent"
15
16SRC_URI = "http://pypi.python.org/packages/source/g/gevent/${SRCNAME}-${PV}.tar.gz"
17SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6"
18SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43"
19
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit setuptools
23
24FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
25SRC_URI += "file://libev-conf.patch"
26SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch"
27
28# The python-gevent has no autoreconf ability
29# and the logic for detecting a cross compile is flawed
30# so always force a cross compile
31do_configure_append() {
32 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure
33}