Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | HOMEPAGE = "http://www.gevent.org" |
| 2 | SUMMARY = "A coroutine-based Python networking library" |
| 3 | DESCRIPTION = "\ |
| 4 | gevent is a coroutine-based Python networking library that uses greenlet \ |
| 5 | to provide a high-level synchronous API on top of the libevent event \ |
| 6 | loop. \ |
| 7 | " |
| 8 | SECTION = "devel/python" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2" |
| 11 | DEPENDS += "python-greenlet libevent" |
| 12 | RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re" |
| 13 | |
| 14 | SRCNAME = "gevent" |
| 15 | |
| 16 | SRC_URI = "http://pypi.python.org/packages/source/g/gevent/${SRCNAME}-${PV}.tar.gz" |
| 17 | SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6" |
| 18 | SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43" |
| 19 | |
| 20 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 21 | |
| 22 | inherit setuptools |
| 23 | |
| 24 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 25 | SRC_URI += "file://libev-conf.patch" |
| 26 | SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch" |
| 27 | |
| 28 | # The python-gevent has no autoreconf ability |
| 29 | # and the logic for detecting a cross compile is flawed |
| 30 | # so always force a cross compile |
| 31 | do_configure_append() { |
| 32 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure |
| 33 | } |