blob: a26e4694f6a1ad497a90e20e870c8176c85157d8 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler220dafd2023-10-04 10:18:08 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Patrick Williams169d7bc2024-01-05 11:33:25 -060012 file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data.patch \
13 file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data-2.patch \
14 file://CVE-2023-6277-Apply-1-suggestion-s-to-1-file-s.patch \
Patrick Williamsf52e3dd2024-01-26 13:04:43 -060015 file://CVE-2023-6228.patch \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 file://CVE-2023-52355-0001.patch \
17 file://CVE-2023-52355-0002.patch \
18 file://CVE-2023-52356.patch \
Andrew Geissler220dafd2023-10-04 10:18:08 -050019 "
Andrew Geissler517393d2023-01-13 08:55:19 -060020
Andrew Geissler220dafd2023-10-04 10:18:08 -050021SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a"
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23# exclude betas
24UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
25
Andrew Geissler8f840682023-07-21 09:09:43 -050026CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
Andrew Geissler517393d2023-01-13 08:55:19 -060027
28inherit autotools multilib_header
29
30CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
31
32PACKAGECONFIG ?= "cxx jpeg zlib lzma \
33 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
34
35PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
36PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
37PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
38PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
39PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
40PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
Patrick Williams864cc432023-02-09 14:54:44 -060041PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
42PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
Andrew Geissler517393d2023-01-13 08:55:19 -060043
44# Convert single-strip uncompressed images to multiple strips of specified
45# size (default: 8192) to reduce memory usage
46PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
47
48# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
49PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
50
51# Control picking up YCbCr subsample info. Disable to support files lacking
52# the tag
53PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
54
55# Support a mechanism allowing reading large strips (usually one strip files)
56# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
57PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
58
59PACKAGES =+ "tiffxx tiff-utils"
60FILES:tiffxx = "${libdir}/libtiffxx.so.*"
61FILES:tiff-utils = "${bindir}/*"
62
63do_install:append() {
64 oe_multilib_header tiffconf.h
65}
66
67BBCLASSEXTEND = "native nativesdk"