blob: b02b15113b5fdef18e4bf420b1348d0e26e2facd [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "An abstract syntax tree for Python with inference support."
2HOMEPAGE = "https://pypi.python.org/pypi/astroid"
3SECTION = "devel/python"
4LICENSE = "LGPL-2.1-only"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
6
Patrick Williams73bd93f2024-02-20 08:07:48 -06007SRC_URI[sha256sum] = "4148645659b08b70d72460ed1921158027a9e53ae8b7234149b1400eddacbb93"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9inherit pypi python_setuptools_build_meta
10
11DEPENDS += "\
Patrick Williams39653562024-03-01 08:54:02 -060012 python3-pytest-runner-native \
13 python3-wheel-native \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060014"
15
16PACKAGES =+ "${PN}-tests"
17
18FILES:${PN}-tests += " \
19 ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \
20 ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \
21"
22
23RDEPENDS:${PN}:class-target += "\
Patrick Williams39653562024-03-01 08:54:02 -060024 python3-lazy-object-proxy \
25 python3-logging \
26 python3-six \
27 python3-wrapt \
28 python3-setuptools \
29 python3-typing-extensions \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060030"
31
32RDEPENDS:${PN}-tests:class-target += "\
Patrick Williams39653562024-03-01 08:54:02 -060033 python3-unittest \
34 python3-xml \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060035"
36
37BBCLASSEXTEND = "native nativesdk"