Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "MQTT version 3.1/3.1.1 client library" |
| 2 | LICENSE = "EPL-1.0 | EDL-1.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \ |
| 4 | file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \ |
| 5 | " |
| 6 | SRCNAME = "paho-mqtt" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | SRC_URI[sha256sum] = "2a8291c81623aec00372b5a85558a372c747cbca8e9934dfe218638b8eefc26f" |
| 11 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame^] | 12 | DEPENDS += "python3-pytest-runner-native" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 13 | |
| 14 | do_install:append() { |
| 15 | install -d -m0755 ${D}${datadir}/${BPN}/examples |
| 16 | cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples |
| 17 | } |
| 18 | |
| 19 | PACKAGES =+ "${PN}-examples" |
| 20 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame^] | 21 | RDEPENDS:${PN}-examples += "${PN} python3-core" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 22 | |
| 23 | FILES:${PN}-examples = "${datadir}/${BPN}/examples" |
| 24 | |
| 25 | RDEPENDS:${PN} = "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame^] | 26 | python3-io \ |
| 27 | python3-logging \ |
| 28 | python3-math \ |
| 29 | python3-netclient \ |
| 30 | python3-threading \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |