blob: 9055772b57049e07789e30a55714f0c91a5811b3 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "MQTT version 3.1/3.1.1 client library"
2LICENSE = "EPL-1.0 | EDL-1.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \
4 file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
5"
6SRCNAME = "paho-mqtt"
7
8inherit pypi setuptools3
9
10SRC_URI[sha256sum] = "2a8291c81623aec00372b5a85558a372c747cbca8e9934dfe218638b8eefc26f"
11
Patrick Williams39653562024-03-01 08:54:02 -060012DEPENDS += "python3-pytest-runner-native"
Andrew Geisslereff27472021-10-29 15:35:00 -050013
14do_install:append() {
15 install -d -m0755 ${D}${datadir}/${BPN}/examples
16 cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples
17}
18
19PACKAGES =+ "${PN}-examples"
20
Patrick Williams39653562024-03-01 08:54:02 -060021RDEPENDS:${PN}-examples += "${PN} python3-core"
Andrew Geisslereff27472021-10-29 15:35:00 -050022
23FILES:${PN}-examples = "${datadir}/${BPN}/examples"
24
25RDEPENDS:${PN} = "\
Patrick Williams39653562024-03-01 08:54:02 -060026 python3-io \
27 python3-logging \
28 python3-math \
29 python3-netclient \
30 python3-threading \
Andrew Geisslereff27472021-10-29 15:35:00 -050031"
32
33BBCLASSEXTEND = "native nativesdk"