blob: eb4b9e897ff564d933c6ccc7a1d0c93ee401c582 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
5
6SRC_URI += "git://github.com/pylint-dev/pylint;branch=maintenance/3.0.x;protocol=https \
7 file://run-ptest \
8 "
Patrick Williams169d7bc2024-01-05 11:33:25 -06009SRCREV = "1a5ffc1f447b77071ffe18a9c6836c09147ee2ed"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060010
11inherit python_setuptools_build_meta ptest
12
Patrick Williams73bd93f2024-02-20 08:07:48 -060013RDEPENDS:${PN} += "\
14 python3-astroid \
15 python3-difflib \
16 python3-dill \
17 python3-isort \
18 python3-json \
19 python3-mccabe \
20 python3-netserver \
21 python3-numbers \
22 python3-pkgutil \
23 python3-platformdirs \
24 python3-shell \
25 python3-tomlkit \
26 "
Patrick Williamsac13d5f2023-11-24 18:59:46 -060027
28RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060029 python3-core \
30 python3-git \
31 python3-py \
32 python3-pytest \
33 python3-pytest-benchmark \
34 python3-pytest-runner \
35 python3-pytest-timeout \
36 python3-pytest-xdist \
37 python3-requests \
38 python3-statistics \
39 python3-tomllib \
40 python3-typing-extensions \
41 python3-unittest-automake-output \
42 "
Patrick Williamsac13d5f2023-11-24 18:59:46 -060043
44S = "${WORKDIR}/git"
45
46do_install_ptest() {
47 install -d ${D}${PTEST_PATH}/tests
48 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
49 install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
50 sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
Patrick Williams73bd93f2024-02-20 08:07:48 -060051 # regression_distutil_import_error_73.py fails to run see
Patrick Williams705982a2024-01-12 09:51:57 -060052 # https://lists.openembedded.org/g/openembedded-devel/topic/103181847
53 rm ${D}${PTEST_PATH}/tests/functional/r/regression_02/regression_distutil_import_error_73.py
Patrick Williamsac13d5f2023-11-24 18:59:46 -060054}
55
56BBCLASSEXTEND = "native nativesdk"