Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY="Pylint is a Python source code analyzer" |
| 2 | HOMEPAGE= "http://www.pylint.org/" |
| 3 | LICENSE = "GPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9" |
| 5 | |
| 6 | SRC_URI += "git://github.com/pylint-dev/pylint;branch=maintenance/3.0.x;protocol=https \ |
| 7 | file://run-ptest \ |
| 8 | " |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 9 | SRCREV = "1a5ffc1f447b77071ffe18a9c6836c09147ee2ed" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 10 | |
| 11 | inherit python_setuptools_build_meta ptest |
| 12 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 13 | RDEPENDS:${PN} += "\ |
| 14 | python3-astroid \ |
| 15 | python3-difflib \ |
| 16 | python3-dill \ |
| 17 | python3-isort \ |
| 18 | python3-json \ |
| 19 | python3-mccabe \ |
| 20 | python3-netserver \ |
| 21 | python3-numbers \ |
| 22 | python3-pkgutil \ |
| 23 | python3-platformdirs \ |
| 24 | python3-shell \ |
| 25 | python3-tomlkit \ |
| 26 | " |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 27 | |
| 28 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 29 | python3-core \ |
| 30 | python3-git \ |
| 31 | python3-py \ |
| 32 | python3-pytest \ |
| 33 | python3-pytest-benchmark \ |
| 34 | python3-pytest-runner \ |
| 35 | python3-pytest-timeout \ |
| 36 | python3-pytest-xdist \ |
| 37 | python3-requests \ |
| 38 | python3-statistics \ |
| 39 | python3-tomllib \ |
| 40 | python3-typing-extensions \ |
| 41 | python3-unittest-automake-output \ |
| 42 | " |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 43 | |
| 44 | S = "${WORKDIR}/git" |
| 45 | |
| 46 | do_install_ptest() { |
| 47 | install -d ${D}${PTEST_PATH}/tests |
| 48 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 49 | install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep |
| 50 | sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 51 | # regression_distutil_import_error_73.py fails to run see |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 52 | # https://lists.openembedded.org/g/openembedded-devel/topic/103181847 |
| 53 | rm ${D}${PTEST_PATH}/tests/functional/r/regression_02/regression_distutil_import_error_73.py |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 54 | } |
| 55 | |
| 56 | BBCLASSEXTEND = "native nativesdk" |