Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame^] | 1 | DESCRIPTION = "Python API for MISP" |
| 2 | HOMEPAGE = "https://github.com/MISP/PyMISP" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "3ccdc6ee48d26d82c77ba3f5d8fd41a79eaaef0ad5619f37a65b060e92f6da4c" |
| 7 | |
| 8 | inherit python_poetry_core pypi |
| 9 | |
| 10 | PIP_INSTALL_PACKAGE = "pymisp" |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | python3-dateutil \ |
| 14 | python3-json \ |
| 15 | python3-jsonschema \ |
| 16 | python3-requests \ |
| 17 | python3-six \ |
| 18 | python3-deprecated \ |
| 19 | python3-wrapt \ |
| 20 | " |
| 21 | |
| 22 | # Fixes: python3-pymisp requires /bin/bash, but no |
| 23 | # providers found in RDEPENDS:python3-pymisp? [file-rdep] |
| 24 | RDEPENDS:${PN} += "bash" |