Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame^] | 1 | SUMMARY = "Socket.IO server" |
| 2 | HOMEPAGE = "https://github.com/miguelgrinberg/python-socketio/" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8" |
| 7 | |
| 8 | inherit pypi python_setuptools_build_meta |
| 9 | |
| 10 | PYPI_PACKAGE = "python-socketio" |
| 11 | |
| 12 | SRC_URI[sha256sum] = "bbcbd758ed8c183775cb2853ba001361e2fa018babf5cbe11a5b77e91c2ec2a2" |
| 13 | |
| 14 | PACKAGECONFIG ?= "asyncio_client client" |
| 15 | PACKAGECONFIG[asyncio_client] = ",,,python3-aiohttp python3-websockets" |
| 16 | PACKAGECONFIG[client] = ",,,python3-requests python3-websocket-client" |
| 17 | |
| 18 | RDEPENDS:${PN} += "\ |
| 19 | python3-engineio \ |
| 20 | python3-logging \ |
| 21 | python3-math \ |
| 22 | python3-pickle \ |
| 23 | python3-json \ |
| 24 | python3-threading \ |
| 25 | python3-six \ |
| 26 | python3-attrs \ |
| 27 | python3-bidict \ |
| 28 | " |