Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed." |
| 2 | DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \ |
| 3 | By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \ |
| 4 | polling, WebSockets, and other applications that require a long-lived connection to each user." |
| 5 | HOMEPAGE = "http://www.tornadoweb.org/en/stable/" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 8 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "72291fa6e6bc84e626589f1c29d90a5a6d593ef5ae68052ee2ef000dfd273dee" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | # Requires _compression which is currently located in misc |
| 14 | RDEPENDS:${PN} += " \ |
| 15 | python3-asyncio \ |
| 16 | python3-certifi \ |
| 17 | python3-compression \ |
| 18 | python3-ctypes \ |
| 19 | python3-email \ |
| 20 | python3-html \ |
| 21 | python3-json \ |
| 22 | python3-misc \ |
| 23 | python3-multiprocessing \ |
| 24 | python3-numbers \ |
| 25 | python3-pkgutil \ |
| 26 | python3-pycurl \ |
| 27 | python3-threading \ |
| 28 | python3-unittest \ |
| 29 | " |
| 30 | |
| 31 | RDEPENDS:${PN}-test += "python3-unittest" |
| 32 | |
| 33 | PACKAGES =+ "\ |
| 34 | ${PN}-test \ |
| 35 | " |
| 36 | |
| 37 | FILES:${PN}-test = " \ |
| 38 | ${libdir}/${PYTHON_DIR}/site-packages/*/test \ |
| 39 | " |