blob: 158e800fed72cf6d8c53b91a2848c180c22d72db [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
Patrick Williams39653562024-03-01 08:54:02 -06008SRC_URI[sha256sum] = "2a29735ea9c18baf14b448846bde5a48030ed267578472d8955cd0e7443a9812"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10RDEPENDS:${PN}:class-target += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060011 python3-datetime \
12 python3-doctest \
13 python3-io \
14 python3-pickle \
15 python3-pprint \
16 python3-threading \
Andrew Geissler517393d2023-01-13 08:55:19 -060017"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060026 python3-pytest \
27 python3-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060028"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
34 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
35
36}