blob: 6ce5e70c2a6d78ab0252f413beb81b4f9843d623 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Library for building powerful interactive command lines in Python"
2DESCRIPTION = "Measures the displayed width of unicode strings in a terminal"
3HOMEPAGE = "https://github.com/jquast/wcwidth"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
6
Patrick Williams169d7bc2024-01-05 11:33:25 -06007SRC_URI[sha256sum] = "f01c104efdf57971bcb756f054dd58ddec5204dd15fa31d6503ea57947d97c02"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 python3-pytest \
17 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25BBCLASSEXTEND = "native nativesdk"