Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "mcelog daemon accounts memory and some other errors in various ways." |
| 2 | DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \ |
| 3 | and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \ |
| 4 | and should run on all Linux systems that need error handling." |
| 5 | HOMEPAGE = "http://mcelog.org/" |
| 6 | SECTION = "System Environment/Base" |
| 7 | |
| 8 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \ |
| 9 | file://run-ptest \ |
| 10 | " |
| 11 | |
| 12 | SRCREV = "2cfdf29b2ef98ccd5ed42cdde8bbe437e0d6412f" |
| 13 | |
| 14 | LICENSE = "GPLv2" |
| 15 | LIC_FILES_CHKSUM = "file://README.md;md5=279840fabb191e6cd9150492d31b0e20" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit autotools-brokensep ptest |
| 20 | |
| 21 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' |
| 22 | |
| 23 | do_install_append() { |
| 24 | install -d ${D}${sysconfdir}/cron.hourly |
| 25 | install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/ |
| 26 | sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron |
| 27 | } |
| 28 | |
| 29 | do_install_ptest() { |
| 30 | install -d ${D}${PTEST_PATH} |
| 31 | cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH} |
| 32 | sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test |
| 33 | } |
| 34 | |
| 35 | RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject" |