Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | # NOTE: mosh-server requires a UTF-8 locale, but there's no way to add |
| 2 | # an explicit dependency for this so you need to ensure this is in your |
| 3 | # image yourself when you install mosh-server. |
| 4 | |
| 5 | SUMMARY = "Remote shell supporting roaming and high-latency connections" |
| 6 | DESCRIPTION = "Remote terminal application that allows roaming, supports \ |
| 7 | intermittent connectivity, and provides intelligent local echo and line \ |
| 8 | editing of user keystrokes. Mosh is a replacement for SSH. It's more \ |
| 9 | robust and responsive, especially over Wi-Fi, cellular, and \ |
| 10 | long-distance links." |
| 11 | HOMEPAGE = "http://mosh.mit.edu" |
| 12 | LICENSE = "GPLv3+" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 14 | |
| 15 | DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter" |
| 16 | |
| 17 | SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz" |
| 18 | SRC_URI[md5sum] = "d961276995936953bf2d5a794068b076" |
| 19 | SRC_URI[sha256sum] = "320e12f461e55d71566597976bd9440ba6c5265fa68fbf614c6f1c8401f93376" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | |
| 23 | PACKAGE_BEFORE_PN += "${PN}-server" |
| 24 | FILES_${PN}-server = "${bindir}/mosh-server" |
| 25 | |
| 26 | NEEDED_PERL_MODULES = "\ |
| 27 | perl-module-socket \ |
| 28 | perl-module-getopt-long \ |
| 29 | perl-module-errno \ |
| 30 | perl-module-io-socket-inet \ |
| 31 | perl-module-posix \ |
| 32 | " |
| 33 | |
| 34 | # mosh uses SSH to authenticate and the client uses OpenSSH-specific features |
| 35 | RDEPENDS_${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}" |
| 36 | # The server seemed not to work with dropbear either |
| 37 | RDEPENDS_${PN}-server += "openssh-sshd ${NEEDED_PERL_MODULES}" |
| 38 | |
| 39 | # Fails to build with thumb-1 (qemuarm) |
| 40 | #| {standard input}: Assembler messages: |
| 41 | #| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4' |
| 42 | #| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5' |
| 43 | #| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6' |
| 44 | #| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7' |
| 45 | #| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs' |
| 46 | ARM_INSTRUCTION_SET = "arm" |