Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require xorg-driver-video.inc |
| 2 | |
| 3 | SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver" |
| 4 | |
| 5 | DESCRIPTION = "omapfb driver supports the basic Texas Instruments OMAP \ |
| 6 | framebuffer." |
| 7 | |
| 8 | LICENSE = "MIT-X & GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=63e2cbac53863f60e2f43343fb34367f" |
| 10 | DEPENDS += "virtual/libx11" |
| 11 | |
| 12 | SRCREV = "33e36c12dde336edbdd34626dd8adfcaebc8fbb8" |
| 13 | PR = "${INC_PR}.7" |
| 14 | PV = "0.1.1+gitr${SRCPV}" |
| 15 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 16 | # Blacklist debian-specific tags in upstream version check |
| 17 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)(?!-)" |
| 18 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | SRC_URI = "git://anonscm.debian.org/collab-maint/xf86-video-omapfb.git \ |
| 20 | file://0001-Prevents-omapfb-from-from-crashing-when-pixelclock-o.patch \ |
| 21 | file://0001-Revert-Set-a-large-CRTC-upper-limit-to-not-prune-lar.patch \ |
| 22 | file://0002-Revert-Set-virtual-size-when-configuring-framebuffer.patch \ |
| 23 | file://0003-force-plain-mode.patch \ |
| 24 | file://0004-blacklist-tv-out.patch \ |
| 25 | file://0005-Attempt-to-fix-VRFB.patch \ |
| 26 | file://0006-omapfb-port-to-new-xserver-video-API.patch \ |
| 27 | file://0007-always_include_xorg_server.h.patch \ |
| 28 | " |
| 29 | |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | CFLAGS += " -I${STAGING_INCDIR}/xorg " |
| 33 | |
| 34 | # Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay) |
| 35 | do_compile_prepend_armv7a () { |
| 36 | sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c |
| 37 | } |