Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "IPv4 link-local address allocator" |
| 2 | DESCRIPTION = "Zeroconf is a program that is used to claim IPv4 \ |
| 3 | link-local addresses. IPv4 link-local addresses are useful when setting \ |
| 4 | up ad-hoc networking between devices without the involvement of a either \ |
| 5 | a DHCP server or network administrator. \ |
| 6 | These addresses are allocated from the 169.254.0.0/16 address range and \ |
| 7 | are normally attached to each Ethernet device in your computer. \ |
| 8 | Addresses are assigned randomly by each host and, in case of collision, \ |
| 9 | both hosts (are supposed to) renumber." |
| 10 | AUTHOR = "Anand Kumria <wildfire@progsoc.uts.edu.au>" |
| 11 | HOMEPAGE = "http://www.progsoc.org/~wildfire/zeroconf/" |
| 12 | LICENSE = "GPLv2+" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4 \ |
| 14 | file://zeroconf.c;beginline=1;endline=13;md5=a5bada96e1e34b08eb7446b28e2630b2" |
| 15 | SECTION = "net" |
| 16 | |
| 17 | PR = "r1" |
| 18 | |
| 19 | SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${BPN}-${PV}.tar.gz \ |
| 20 | file://compilefix.patch \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 21 | file://makefile-add-ldflags.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | file://zeroconf-default \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 23 | file://debian-zeroconf \ |
| 24 | file://0001-zeroconf-Rename-arp_op-to-avoid-namespace-conflicts-.patch \ |
| 25 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | |
| 27 | SRC_URI[md5sum] = "bdafb16b008ebb5633e4e581f77821d2" |
| 28 | SRC_URI[sha256sum] = "a8c74df127753e2310fa1e072f3c9ca44a404bb0bbce9cfec7a84c6dff8bec7b" |
| 29 | |
| 30 | do_install () { |
| 31 | install -d ${D}${sbindir} |
| 32 | install -d ${D}${sysconfdir}/network/if-up.d |
| 33 | install -d ${D}${sysconfdir}/default |
| 34 | install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf |
| 35 | install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf |
| 36 | install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf |
| 37 | } |