Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "System performance benchmark" |
| 2 | HOMEPAGE = "http://github.com/akopytov/sysbench" |
| 3 | SECTION = "console/tests" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 6 | |
| 7 | inherit autotools |
| 8 | |
| 9 | # The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from |
| 10 | # Launchpad until the next release is available from Github. |
| 11 | SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz" |
| 12 | |
| 13 | SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d" |
| 14 | SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e" |
| 15 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 17 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 18 | PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio," |
| 19 | PACKAGECONFIG[mysql] = "--with-mysql \ |
| 20 | --with-mysql-includes=${STAGING_INCDIR}/mysql \ |
| 21 | --with-mysql-libs=${STAGING_LIBDIR}, \ |
| 22 | --without-mysql,mysql5" |
| 23 | |
| 24 | do_configure_prepend() { |
| 25 | touch ${S}/NEWS ${S}/AUTHORS |
| 26 | } |